sexta-feira, 26 de março de 2010

5° Algoritmo "Calcula preços";

5) Uma pessoa foi ao supermercado e comprou cinco produtos. Entre com o nome dos produtos e seu respectivo preço e no final escreva o total gasto.

Algoritmo "Calcula o preço de produtos";
Var;
P1, P2, P3, P4,P5: Alfa-numérico;
M1, M2, M3, M4, M5: Texto;
Total: Real;

Início
Escreva ("Caixa do Supermercado");
Escreva("Digite mercadoria")
Leia (M1);
Escreva("Digite preço");
Leia (P1);
Escreva("Digite mercadoria");
Leia (M2);
Escreva("Digite preço");
Leia (P2);
Escreva("Digite mercadoria");
Leia (M3);
Escreva("Digite preço");
Leia (P3);
Escreva("Digite mercadoria");
Leia (M4);
Escreva("Digite preço");
Leia (P4);
Escreva("Digite mercadoria");
Leia (M5);
Escreva("Digite preço");
Leia (P5);
Total ← (P1 + P2 + P3 + P4 + P5);
Escreva ("O valor total é:" Total);
Fim

2 comentários:

  1. Este comentário foi removido pelo autor.

    ResponderExcluir
  2. PRA QUE ESCREVER UM ALGORITMO DESSE TAMANHO?

    Você até pode escrever um algoritmo com essa gigantesca estrutura, mas existe uma questão importante: E SE O CLIENTE COMPRASSE NÃO 5, MAS 999999999999 PRODUTOS? VOCÊ IRIA ESCREVER UM CÓDIGO AINDA MAIOR?

    RESPOSTA: NÃO!

    Uma estrutura como essa não é usual!

    Além de dar trabalho, seu algoritmo em alguns pontos, foi escrito errado. Podemos, para uma estrutura repetitiva como essa, usar as estruturas PARA, ENQUANTO ou REPITA.

    Não vou citar os pontos onde errou, mas vou dar uma solução prática para resolver o seu problema:

    algoritmo "Soma de preços"
    // Função : Calcular o total gasto
    // Autor : Daniel Depolo
    // Data : 25/05/2013
    // Seção de Declarações

    var
    t, v : real
    i, p : inteiro

    inicio
    // Seção de Comandos

    escreva ("Produtos: ")
    leia (p)
    escreval ()
    para i de 1 ate p passo 1 faca
    escreva ("Preço do produto", i, ": ")
    leia (v)
    t <- t + v
    fimpara
    escreval()

    t <- t

    escreva ("Total: ", t)
    escreval ()
    fimalgoritmo

    ResponderExcluir