segunda-feira, 12 de abril de 2010

2) Questão: Algoritmo "Infantil, juvenil ou adulto";

2) Elabore um algoritmo que dada a idade de um nadador classifica-o em uma das seguintes categorias:

Infantil A = 5 - 7 anos
Infantil B = 8-10 anos
Juvenil A = 11-13 anos
Juvenil B = 14-17 anos
Adulto = maiores de 18 anos

Algoritmo "Infantil, juvenil ou adulto";

Var
Idade: Real;
Infantil A, Infantil B: Texto;

Início
Escreva ("Digite a idade do nadador");
Leia (idade);
Se
(Idade > 5) e (Idade > 7);
Então
Escreva ("Infantil A");
Fim se
Se
(Idade > 8) e (Idade > 10);
Então
Escreva ("Infantil B");
Fim se
Se
(Idade > 11) e (Idade < 13);
Então
Escreva ("Juvenil A");
Fim se
Se
(Idade > 14) e (Idade < 17);
Então
Escreva ("Juvenil B");
Fim se
Se
(Idade > 18);
Então
Escreva ("Adulto");
Fim se
Fim

Nenhum comentário:

Postar um comentário