segunda-feira, 12 de abril de 2010

3) Questão: Algoritmo "Crédito";

3) Um banco concederá um crédito especial aos seus clientes, variável com o saldo médio no último ano. Faça um algoritmo que leia o saldo médio de um cliente e calcule o valor do crédito de acordo com a tabela abaixo. Mostre uma mensagem informando o saldo médio e o valor do crédito.
Saldo médio
Percentual
De 0 a 200, Nenhum crédito
De 201 a 400, 20% do valor do saldo médio
De 401 a 600, 30% do valor do saldo médio
Acima de 601, 40% do valor do saldo médio

Algoritmo "Crédito";
Var
Saldo, valor: Real

Início
Escreva ("Bem vindo ao banco");
Escreva ("Digite o saldo desejado");
Leia (saldo);
Se
(saldo > = 0) e (saldo < = 200);
Então
Escreva ("Você não tem crédito para a operação");
Fim se
Se
(saldo > = 201) e (saldo < = 400);
Então
valor ← (saldo*0,2);
Escreva ("O seu limite de crédito é:"valor);
Fim se
Se
(saldo > = 401) e (saldo < = 600);
Então
valor ← (saldo*0,3);
Escreva ("O seu limite de crédito é:"valor);
Se
(saldo > = 601);
Então
Escreva ("O seu limite de crédito é:"valor);
Fim se
Fim

3 comentários:

  1. Desenvolva os algoritmos, diagramas de blocos e codificação em português estruturado dos seguintes programas:
    Para estabelecer esse algoritmo, é necessário, em primeiro lugar, saber o que realmente é um triângulo. Se você não souber o que é um triângulo, conseqüentemente, não conseguirá resolver o problema. Triângulo é uma forma geométrica (polígono) composta por três lados, sendo que cada lado é menor que a soma dos outros dois lados. Perceba que isto é uma regra (uma condição) e deve ser considerada. É um triângulo quando AB e B<>C, e é eqüilátero quando possui todos os lados iguais, sendo A=B e B=C.
    1. Ler três valores para os lados de um triângulo : A, B e C;
    2. Verificar se cada lado é menor que a soma dos outros dois lados;
    3. Sendo a figura um triângulo, verificar se é eqüilátero , isósceles ou escaleno;
    4. Caso os lados fornecidos não caracterizem um triângulo, avisar a ocorrência.

    ResponderExcluir
  2. Olá, Lucas.
    Tentei falar com você pelo email que disponibilizou na pagina, porem dá inexistente e meu email volta.
    Att: Ursula Rodrigues

    ursularodriguesmoda@yahoo.com.br

    ResponderExcluir
  3. Olá, Lucas.
    Tentei falar com você pelo email que disponibilizou na pagina, porem dá inexistente e meu email volta.
    Att: Ursula Rodrigues

    ursularodriguesmoda@yahoo.com.br

    ResponderExcluir